Config Guides

Home 9 Config Guides
Supported BGP Communities

We support the following standard and large communities. Kindly use large communities exclusively if your device supports it.

 

Standard BGP Communities.

Community Description
0:peer-as Prevent advertisement of a prefix to peer-as
0:36932 Prevent advertisent of a prefix to all peers
36932:peer-as Advertise a prefix to peer-as only (used in conjunction with [0:36932])
36932:36932 Advertise a prefix to all peers (Implicit default)

 

Large BGP Communities

Community Description
36932:0:peer-as Prevent advertisement of a prefix to peer-as
36932:0:0 Prevent advertisent of a prefix to all peers
36932:1:peer-as Advertise a prefix to peer-as only (used in conjunction with [36932:1:peer-as])
36932:1:0 Advertise a prefix to all peers (Implicit default)

 

There is also support for path prepending using the following large communities.

Community Description
36932:101:peer-as Prepend to peer-as once
36932:102:peer-as Prepend to peer-as twice
36932:103:peer-as Prepend to peer-as three times

 

CISCO IOS

Configurable Items.

  • Peer IP addresses – (provisioned by the IXP)
  • Routing session with ASN
  • Neighbor peer
  • IP Address-family activation

1). Configure peering IP address

  • Interface gigabitethernet <interface-id-number>
  • ip address <ip-address> <subnet mask>
  • no shutdown

2). Activate BGP routing session

  • Router bgp <MY_ASN>

3). Established peer with neighbor

  • neighbor <neighbor-ip> remote-as<NEIGHBOR_ASN>

4). To receive updates from the route server, which will not have its AS first in the AS_PATH, specify “no bgp enforce-first-as”

  • no bgp enforce-first-as

5) . Activate IP address-Family (IPv4, IPv6)

  • address-family ipv4 unicast
  • neighbor <neighbor-ip> activate
  • neighbor <neighbor-ip> soft-reconfiguration inbound

  

CISCO IOS-XR

Configurable Items.

  • Peer IP addresses – (provisioned by the IXP)
  • Routing Policy which enables you received update from neighbor
  • Routing session with ASN
  • Activate address family BGP global configuration (IPv4, IPv6)
  • Disable BGP enforce-first-as
  • Neighbor peer
  • IP Address-family activation
  1. Configure Peer IP Address
    • Interface gigabitethernet <interface-id-number>
    • ipv4 address <ip-address/prefix-length>
    • no shutdown
    • commit
    • exit
  2. Set routing policy to be attached to BGP neighbor. The rules should at a minimum “pass” traffic. 
    • route-policy <policy-name>
    • pass
    • end-policy
    • commit
  3. Activate BGP Routing session
    • router bgp <my asn>
    • commit
  4. Activate global BGP address-family
    • address-family ipv4 unicast
    • commit
    • exit
  5. To receive updates from the route server, which will not have its AS first in the AS_PATH,  configure “bgp enforce-first-as disable”
    • bgp enforce-first-as disable
    • commit
  6. Establish peer with neighbor
    • neighbor <neighbor ip >
    • remote-as<neighbor_asn>
    • commit
  7. Activate IP address-Family for neighbor peer (IPv4, IPv6)
    • neighbor <neighbor ip >
    • address-family ipv4 unicast
    • soft-reconfiguration inbound
    • commit
  8. Attach routing policy to the neighbor session
    • neighbor <neighbor ip >
    • route policy <policy name> in
    • route policy <policy name> out
    • commit

CISCO IOS-XE

Configurable Items.

  • Peer IP addresses – (provisioned by the IXP)
  • Routing session with ASN
  • Disable BGP enforce-first-as
  • Neighbor peer
  • IP Address-family activation

 

1). Configure peering IP address

  • Interface gigabitethernet <interface-id-number>
  • ip address <ip-address> <subnet mask>
  • no shutdown

2). Activate BGP routing session

  • router bgp <MY_ASN>

3). To receive updates from the route server, which will not have its AS first in the AS_PATH, specify “no bgp enforce-first-as”

  • no bgp enforce-first-as

4). Established peer with neighbor

  • neighbor <neighbor-ip> remote-as<NEIGHBOR_ASN>

5) . Activate IP address-Family (IPv4, IPv6)

  • address-family ipv4 unicast
  • neiughbor <neighbor-ip> activate
  • neighbor <neighbor-ip> soft-reconfiguration inbound
MIKROTIK ROUTER OS 6

Configurable Items.

  • Peer IP addresses – (provisioned by the IXP)
  • BGP routing Instance session with ASN and BGP router-id
  • Neighbor peer establishment 

1). Configure peering IP address

  • ip address add address=<ip-address/subnet_mask> interface=ether<interface-id-number>

2). Activate BGP routing Instance.

  • routing bgp instance add as=<my_asn> name=<routing_instance_name> router-id=<router-id or my-peering-ip>

3). Establish BGP neighbor peer  

  • routing bgp peer add instance=<routing_instance_name> name=<descriptive_peer_name> remote-address=<neighbor_ip> remote-as=<neighbor_asn>

 

Juniper OS

Configurable Items.

  • Peer IP addresses – (provisioned by the IXP)
  • Routing session with ASN
  • Neighbor peer

 

1). Configure peering IP address

  • set interfaces ge-0/0/0 unit 0 family inet address <x.x.x.x/prefix-length>
  • commit

2). Activate BGP routing session

  • set routing-options autonomous-system <my_asn>
  • commit

3). Established peer with neighbor

  • edit protocols bgp
  • edit group ebgp-peers
  • set neighbor <neighbor_ip> peer-as <neighbor_asn>
  • set type external
  • commit